Mail Storage Maintenance
Incident Report for Shivam ITS
Resolved
This incident has been resolved.
Posted Mar 15, 2021 - 04:50 IST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 15, 2021 - 04:41 IST
Identified
We are performing unscheduled Mail service maintenance. Clients will experience from 30 to 60 minutes long service interruptions. We will provide further updates as necessary. Thank You for Your patience.
Posted Mar 15, 2021 - 04:27 IST
This incident affected: Core Services (Email service).